summaryrefslogtreecommitdiffstats
path: root/mobile-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-02-11 16:13:01 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-01-26 16:42:35 -0800
commit9de296f3dd6fc93ad4cfa68528cfa733e585e352 (patch)
treee26517b46429c8737b2c906f5884d89bdccf4df2 /mobile-widgets/CMakeLists.txt
parent49616c1842f3cf2848606b25e204b25610ce928e (diff)
downloadsubsurface-9de296f3dd6fc93ad4cfa68528cfa733e585e352.tar.gz
mobile-widgets: add themeInterface
Currently subsurfaceTheme resides in main.qml, where it does not naturally belong. Add C++ class that will replace subsurfaceTheme in main.qml in a 1-1 manner. This opens future posibilities - on top of the 3 themes, allow users to select colors/fonts - add stylesheets to Template* components - make day/night shift automatically. Signed-off-by: jan Iversen <jan@casacondor.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'mobile-widgets/CMakeLists.txt')
-rw-r--r--mobile-widgets/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/mobile-widgets/CMakeLists.txt b/mobile-widgets/CMakeLists.txt
index 6c1747dbc..9f5ddaf47 100644
--- a/mobile-widgets/CMakeLists.txt
+++ b/mobile-widgets/CMakeLists.txt
@@ -3,6 +3,7 @@
set(SUBSURFACE_MOBILE_SRCS
qmlinterface.cpp
qmlmanager.cpp
+ themeinterface.cpp
qml/kirigami/src/columnview.cpp
qml/kirigami/src/delegaterecycler.cpp
qml/kirigami/src/enums.cpp