summaryrefslogtreecommitdiffstats
path: root/packaging/ubuntu/debian
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2014-12-03 09:38:52 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2014-12-03 09:39:57 -0800
commit8f224c17373c8714ffeb13127a4e266a47990a16 (patch)
tree1d4f3927841b021929f9fc2ffb6402b5faaa015c /packaging/ubuntu/debian
parent89c333e4b6cbfaaaccabcf5bf967d49036680fbe (diff)
downloadsubsurface-8f224c17373c8714ffeb13127a4e266a47990a16.tar.gz
Ubuntu packaging: move support files into debian directory
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'packaging/ubuntu/debian')
-rw-r--r--packaging/ubuntu/debian/changelog3
-rw-r--r--packaging/ubuntu/debian/control44
-rw-r--r--packaging/ubuntu/debian/copyright32
-rwxr-xr-xpackaging/ubuntu/debian/rules37
-rw-r--r--packaging/ubuntu/debian/source.lintian-overrides8
5 files changed, 124 insertions, 0 deletions
diff --git a/packaging/ubuntu/debian/changelog b/packaging/ubuntu/debian/changelog
new file mode 100644
index 000000000..e1fb94cb0
--- /dev/null
+++ b/packaging/ubuntu/debian/changelog
@@ -0,0 +1,3 @@
+
+ * Daily build - check git revision for full changelog
+
diff --git a/packaging/ubuntu/debian/control b/packaging/ubuntu/debian/control
new file mode 100644
index 000000000..874f25c2d
--- /dev/null
+++ b/packaging/ubuntu/debian/control
@@ -0,0 +1,44 @@
+Source: subsurface
+Section: utils
+Priority: optional
+Maintainer: Dirk Hohndel <dirk@hohndel.org>
+Build-Depends: asciidoc,
+ debhelper (>= 9),
+ libgconf2-dev,
+ libtool,
+ libxml2-dev,
+ libxslt-dev,
+ libsoup2.4-dev,
+ pkg-config,
+ txt2html,
+ libzip-dev,
+ libsqlite3-dev,
+ autoconf,
+ automake,
+ cmake,
+ dpkg-dev (>= 1.16.1.1),
+ libusb-dev,
+ dh-autoreconf,
+ libz-dev,
+ libssl-dev,
+ git,
+ qttools5-dev-tools,
+ qt5-qmake,
+ libqt5svg5-dev,
+ libqt5webkit5-dev,
+ qtscript5-dev,
+ qt5-default
+Standards-Version: 3.9.5
+Homepage: http://subsurface-divelog.hohndel.org
+#Vcs-Git: git://git.debian.org/collab-maint/subsurface-4.2.90.git
+#Vcs-Browser: http://git.debian.org/?p=collab-maint/subsurface-4.2.90.git;a=summary
+
+Package: subsurface
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Dive log program
+ Subsurface is an open source divelog program that runs on Windows, Mac and Linux.
+ Subsurface is able to track single- and multi-tank dives using air, Nitrox or
+ TriMix. It also allows logging of weights and exposure protection used, dive
+ masters and dive buddies and enables the user to rate dives and provide
+ additional dive notes.
diff --git a/packaging/ubuntu/debian/copyright b/packaging/ubuntu/debian/copyright
new file mode 100644
index 000000000..75e69b368
--- /dev/null
+++ b/packaging/ubuntu/debian/copyright
@@ -0,0 +1,32 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: subsurface-4.2.90
+Source: <url://subsurface-divelog.org>
+
+Files: *
+Copyright: 2011-2014 Dirk Hohndel, Linus Torvalds, Tomaz Canabrava and others
+License: GPL-2.0
+
+Files: debian/*
+Copyright: 2014 Dirk Hohndel <dirk@hohndel.org>
+License: GPL-2.0
+
+License: GPL-2.0
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of version 2 of the GNU General Public License as published
+ by the Free Software Foundation
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 2 can be found in "/usr/share/common-licenses/GPL-2".
+
+# Please also look if there are files or directories which have a
+# different copyright/license attached and list them here.
+# Please avoid to pick license terms that are more restrictive than the
+# packaged work, as it may make Debian's contributions unacceptable upstream.
diff --git a/packaging/ubuntu/debian/rules b/packaging/ubuntu/debian/rules
new file mode 100755
index 000000000..76ac5b98a
--- /dev/null
+++ b/packaging/ubuntu/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+
+%:
+ dh $@
+
+override_dh_auto_clean:
+ (cd libdivecomputer ; make clean || true)
+ make clean || true
+ rm -rf libgit2/build
+ rm -rf marble-build
+ rm -f ssrf-version.h
+ rm -f subsurface
+ rm -f Makefile
+
+override_dh_auto_configure:
+ (cd libdivecomputer ; autoreconf --install ; ./configure ; make -j8 )
+ (mkdir libgit2/build ; cd libgit2/build ; cmake -DBUILD_SHARED_LIBS=OFF .. ; sed -i 's/.so$/.a/' CMakeCache.txt ; make -j8 )
+ (mkdir marble-build ; cd marble-build ; \
+ cmake -DQTONLY=ON -DBUILD_MARBLE_APPS=OFF -DBUILD_MARBLE_EXAMPLES=OFF -DBUILD_MARBLE_TESTS=OFF -DBUILD_MARBLE_TOOLS=OFF -DBUILD_SHARED_LIBS=OFF -DBUILD_TESTING=OFF -DWITH_DESIGNER_PLUGIN=OFF -DBUILD_WITH_DBUS=OFF ../marble-source ; \
+ make -j8 ; \
+ mkdir include ; cd include ; for i in `find ../../marble-source -name \*.h` ; do ln -s $$i . ; echo ln -s $$i . ; done ; \
+ ln -s . marble )
+ qmake LIBDCDEVEL=./libdivecomputer LIBGIT2DEVEL=./libgit2 LIBGIT2STATIC=1 LIBMARBLEDEVEL=./marble-build LIBMARBLESTATIC=1 subsurface.pro
+
+override_dh_installchangelogs:
+ dh_installchangelogs
+ dh_installchangelogs ReleaseNotes.txt
+ txt2html Documentation/user-manual.txt > Documentation/user-manual.html
+ mkdir -p debian/subsurface/usr/share/doc/subsurface
+ cp Documentation/user-manual.txt debian/subsurface/usr/share/doc/subsurface/
+ cp Documentation/user-manual.html debian/subsurface/usr/share/doc/subsurface/html
+
diff --git a/packaging/ubuntu/debian/source.lintian-overrides b/packaging/ubuntu/debian/source.lintian-overrides
new file mode 100644
index 000000000..a2065afeb
--- /dev/null
+++ b/packaging/ubuntu/debian/source.lintian-overrides
@@ -0,0 +1,8 @@
+# We use the package
+subsurface source: source-is-missing theme/jqplot.canvasAxisTickRenderer.min.js
+subsurface source: source-is-missing theme/jqplot.canvasTextRenderer.min.js
+subsurface source: source-is-missing theme/jqplot.highlighter.min.js
+subsurface source: source-is-missing theme/jquery.jqplot.min.js
+subsurface source: source-is-missing theme/jquery.min.js
+
+