summaryrefslogtreecommitdiffstats
path: root/profile-widget/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-02 19:54:34 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-02 19:54:34 -0800
commit8ea7f404574c2ee571d2dde6bb6be3791e962150 (patch)
tree6a050178bfc71bf10558968f2a3bc0a12d8c525f /profile-widget/CMakeLists.txt
parentb273c1b0ca7bfe933e7c83742f1610f6bbe3f4d3 (diff)
parentdf7818a9b8495285b4d9812e5d6d50d6f9c08813 (diff)
downloadsubsurface-8ea7f404574c2ee571d2dde6bb6be3791e962150.tar.gz
Merge branch 'cmakeAndPreferences'
Diffstat (limited to 'profile-widget/CMakeLists.txt')
-rw-r--r--profile-widget/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/profile-widget/CMakeLists.txt b/profile-widget/CMakeLists.txt
new file mode 100644
index 000000000..f0a1d8439
--- /dev/null
+++ b/profile-widget/CMakeLists.txt
@@ -0,0 +1,19 @@
+# the profile widget
+set(SUBSURFACE_PROFILE_LIB_SRCS
+ profilewidget2.cpp
+ diverectitem.cpp
+ divepixmapitem.cpp
+ divelineitem.cpp
+ divetextitem.cpp
+ animationfunctions.cpp
+ divecartesianaxis.cpp
+ diveprofileitem.cpp
+ diveeventitem.cpp
+ divetooltipitem.cpp
+ ruleritem.cpp
+ tankitem.cpp
+)
+source_group("Subsurface Profile" FILES ${SUBSURFACE_PROFILE_LIB_SRCS})
+
+add_library(subsurface_profile STATIC ${SUBSURFACE_PROFILE_LIB_SRCS})
+target_link_libraries(subsurface_profile ${QT_LIBRARIES}) \ No newline at end of file