summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tcanabrava@kde.org>2017-06-05 18:16:12 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-06-11 13:55:41 -0700
commit0ea6f13891cff45d1da7cb23a5e07a2080827b78 (patch)
treebefb85625f000382fa5263b1cc04911c775cd326 /qt-models/CMakeLists.txt
parente7cd1785c420ba797477c8bd272ee02547731048 (diff)
downloadsubsurface-0ea6f13891cff45d1da7cb23a5e07a2080827b78.tar.gz
Add a messageHandler to take care of qDebug & friends on QML
all qDebug / qCDebug and friends now will be properly logged into developer -> log, on QML. Signed-off-by: Tomaz Canabrava <tcanabrava@kde.org> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index cbdf47501..90b6da433 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -23,6 +23,7 @@ set(SUBSURFACE_MODELS_LIB_SRCS
divelistmodel.cpp
gpslistmodel.cpp
diveimportedmodel.cpp
+ messagehandlermodel.cpp
)
source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})