summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-03-03 22:19:32 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-05 13:27:54 -0800
commit47e9a771ba8fef590b240923e68edf6402242354 (patch)
tree57c1c856a9bce4a25a15f68a482bfe23df4ed905 /qt-models/CMakeLists.txt
parent69508d7123264ab3fa6ba6bf7ffba93784116563 (diff)
downloadsubsurface-47e9a771ba8fef590b240923e68edf6402242354.tar.gz
CMake: do not expand variables in if-expressions
CMake will do the expansion internally itself. Not doing it here is not only less code, it also makes sure one does not accidentially get a double expansion. Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index 896ee9930..eb754d7f1 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -35,11 +35,11 @@ set(SUBSURFACE_MOBILE_MODELS_LIB_SRCS
gpslistmodel.cpp
)
-if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
+if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
add_library(subsurface_models_desktop STATIC ${SUBSURFACE_GENERIC_MODELS_LIB_SRCS}
${SUBSURFACE_DESKTOP_MODELS_LIB_SRCS})
target_link_libraries(subsurface_models_desktop ${QT_LIBRARIES})
-elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
+elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
add_library(subsurface_models_mobile STATIC ${SUBSURFACE_GENERIC_MODELS_LIB_SRCS}
${SUBSURFACE_MOBILE_MODELS_LIB_SRCS})
target_link_libraries(subsurface_models_mobile ${QT_LIBRARIES})