summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-03-25 22:47:44 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-27 14:07:32 -0700
commit7635ee3e776f7adb96dda70ea21920569368ae30 (patch)
tree0def9ccb934b2565765f5713ae3b4bb6a30b8b38 /qt-models/CMakeLists.txt
parent8526fea973a03724a9121002512fae516c6000ed (diff)
downloadsubsurface-7635ee3e776f7adb96dda70ea21920569368ae30.tar.gz
CMake: add headers to targets
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt46
1 files changed, 34 insertions, 12 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index eb754d7f1..449b450e7 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -3,36 +3,58 @@
# models used both mobile and desktop builds
set(SUBSURFACE_GENERIC_MODELS_LIB_SRCS
- diveplotdatamodel.cpp
- diveimportedmodel.cpp
completionmodels.cpp
+ completionmodels.h
+ diveimportedmodel.cpp
+ diveimportedmodel.h
divelocationmodel.cpp
+ divelocationmodel.h
+ diveplotdatamodel.cpp
+ diveplotdatamodel.h
maplocationmodel.cpp
+ maplocationmodel.h
)
# models exclusively used in desktop builds
set(SUBSURFACE_DESKTOP_MODELS_LIB_SRCS
- divepicturemodel.cpp
cleanertablemodel.cpp
+ cleanertablemodel.h
+ cylindermodel.cpp
+ cylindermodel.h
+ divecomputerextradatamodel.cpp
+ divecomputerextradatamodel.h
+ divecomputermodel.cpp
+ divecomputermodel.h
+ divepicturemodel.cpp
+ divepicturemodel.h
+ diveplannermodel.cpp
+ diveplannermodel.h
+ divetripmodel.cpp
+ divetripmodel.h
+ filtermodels.cpp
+ filtermodels.h
models.cpp
+ models.h
tankinfomodel.cpp
+ tankinfomodel.h
treemodel.cpp
- cylindermodel.cpp
- yearlystatisticsmodel.cpp
- weightsysteminfomodel.cpp
+ treemodel.h
weightmodel.cpp
- filtermodels.cpp
- divecomputermodel.cpp
- divetripmodel.cpp
- diveplannermodel.cpp
- divecomputerextradatamodel.cpp
+ weightmodel.h
+ weightsysteminfomodel.cpp
+ weightsysteminfomodel.h
+ yearlystatisticsmodel.cpp
+ yearlystatisticsmodel.h
)
# models exclusively used in mobile builds
set(SUBSURFACE_MOBILE_MODELS_LIB_SRCS
divelistmodel.cpp
- messagehandlermodel.cpp
+ divelistmodel.h
gpslistmodel.cpp
+ gpslistmodel.h
+ messagehandlermodel.cpp
+ messagehandlermodel.h
)
if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")