summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2019-11-11 21:16:48 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-03-09 12:41:11 -0700
commit35b33b8c6a86b6add120aaa1c65f37d21f6a53a8 (patch)
tree01e88c4b9dec612f354d8a151f4c6cc0c6fcea80 /qt-models/CMakeLists.txt
parent90f8c1138e3869803bf363be6da117db0248e179 (diff)
downloadsubsurface-35b33b8c6a86b6add120aaa1c65f37d21f6a53a8.tar.gz
mobile/divelist: add first version of new MobileListModel proxy model
Create a model which represents all top-level items and, potentially, one expanded trip as a flat list. Pass down roles to the source model and let the source model handle that. We'll have to do some ifdef-ery, but so be it. Additionally, compile the base model on mobile as well. This contains a couple of hacks to make things compile at all. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index 8cdeecd25..aa3aa1886 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -17,6 +17,8 @@ set(SUBSURFACE_GENERIC_MODELS_LIB_SRCS
diveplannermodel.h
diveplotdatamodel.cpp
diveplotdatamodel.h
+ divetripmodel.cpp
+ divetripmodel.h
maplocationmodel.cpp
maplocationmodel.h
models.cpp
@@ -39,6 +41,10 @@ set(SUBSURFACE_DESKTOP_MODELS_LIB_SRCS
divetripmodel.h
filtermodels.cpp
filtermodels.h
+ models.cpp
+ models.h
+ tankinfomodel.cpp
+ tankinfomodel.h
treemodel.cpp
treemodel.h
weightmodel.cpp
@@ -59,6 +65,8 @@ set(SUBSURFACE_MOBILE_MODELS_LIB_SRCS
gpslistmodel.h
messagehandlermodel.cpp
messagehandlermodel.h
+ mobilelistmodel.cpp
+ mobilelistmodel.h
)
if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")