summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Lubomir I. Ivanov <neolit123@gmail.com>2015-11-09 20:42:11 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-10 09:08:10 -0800
commit36314a86f817c0d2c56aeca497ce3e29ba8db54a (patch)
tree2ce9e1cb7c9c8a267410afe264837c073140707d /qt-models/CMakeLists.txt
parentb8c71ef6cd3c5724be620725087c11aae290314a (diff)
downloadsubsurface-36314a86f817c0d2c56aeca497ce3e29ba8db54a.tar.gz
qt-models: remove obsolete printer related classes
The profileprintmodel.cpp/.h and the tableprintmode.cpp/.h pairs are obsolete. The print layouting is now handled via the Grantlee library and HTML. Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index c9bcf5c3d..c35ca4377 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -11,12 +11,10 @@ set(SUBSURFACE_MODELS_LIB_SRCS
weightmodel.cpp
divecomputermodel.cpp
treemodel.cpp
- tableprintmodel.cpp
yearlystatisticsmodel.cpp
divetripmodel.cpp
divecomputerextradatamodel.cpp
completionmodels.cpp
- profileprintmodel.cpp
divepicturemodel.cpp
diveplotdatamodel.cpp
divelocationmodel.cpp
@@ -26,4 +24,4 @@ set(SUBSURFACE_MODELS_LIB_SRCS
source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})
add_library(subsurface_models STATIC ${SUBSURFACE_MODELS_LIB_SRCS})
-target_link_libraries(subsurface_models ${QT_LIBRARIES}) \ No newline at end of file
+target_link_libraries(subsurface_models ${QT_LIBRARIES})