summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jan Mulder <jlmulder@xs4all.nl>2018-01-28 15:21:28 +0100
committerGravatar Jan Mulder <jlmulder@xs4all.nl>2018-01-31 14:48:14 +0100
commit494ad2654082d85846cb902556921ab62a6dbb14 (patch)
treefc130087b7c90cf38b8bbf6513f1ed08cf05755f /qt-models/CMakeLists.txt
parent83259008e763d3cc120c826f58f91a0ff62b6b92 (diff)
downloadsubsurface-494ad2654082d85846cb902556921ab62a6dbb14.tar.gz
mobile cleanup: restyle construction of locationlist
See also e6e1473e6. The construction of the locationlist was not the same as the 3 previous lists, and it needs the inclusion of a new model file (divelocationmodel.cpp) in the mobile app. In addition, as the mobile app is mainly interested in a simple stringList (model) to populate a HintsText field (or maybe later a combobox), this stringlist is added to the model, to easy interfacing with QML. Signed-off-by: Jan Mulder <jlmulder@xs4all.nl>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index f24f6d2a5..d286fd3eb 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -6,6 +6,7 @@ set(SUBSURFACE_GENERIC_MODELS_LIB_SRCS
diveplotdatamodel.cpp
diveimportedmodel.cpp
completionmodels.cpp
+ divelocationmodel.cpp
)
# models exclusively used in desktop builds
@@ -25,7 +26,6 @@ set(SUBSURFACE_DESKTOP_MODELS_LIB_SRCS
divetripmodel.cpp
diveplannermodel.cpp
divecomputerextradatamodel.cpp
- divelocationmodel.cpp
ssrfsortfilterproxymodel.cpp
)