summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-09-03 15:25:01 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-30 10:36:49 -0700
commit50ec7200e66637abefe685e1875f3d4de2101158 (patch)
treebee7515ccff2b70dfa0b66994d19950e6370e813 /qt-models/CMakeLists.txt
parent45c97640739198cf9a9cc5c42e81fb9811702b46 (diff)
downloadsubsurface-50ec7200e66637abefe685e1875f3d4de2101158.tar.gz
Single CMake to handle the models
This one was pretty easy because of the work I did a few months ago to separate the models from the UI. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
new file mode 100644
index 000000000..463d61412
--- /dev/null
+++ b/qt-models/CMakeLists.txt
@@ -0,0 +1,28 @@
+# the data models that will interface
+# with the views.
+set(SUBSURFACE_MODELS_LIB_SRCS
+ cleanertablemodel.cpp
+ cylindermodel.cpp
+ diveplannermodel.cpp
+ models.cpp
+ filtermodels.cpp
+ tankinfomodel.cpp
+ weigthsysteminfomodel.cpp
+ weightmodel.cpp
+ divecomputermodel.cpp
+ treemodel.cpp
+ tableprintmodel.cpp
+ yearlystatisticsmodel.cpp
+ divetripmodel.cpp
+ divecomputerextradatamodel.cpp
+ completionmodels.cpp
+ profileprintmodel.cpp
+ divepicturemodel.cpp
+ diveplotdatamodel.cpp
+ divelocationmodel.cpp
+ divesitepicturesmodel.cpp
+ ssrfsortfilterproxymodel.cpp
+)
+source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})
+add_library(subsurface_models STATIC ${SUBSURFACE_MODELS_LIB_SRCS})
+target_link_libraries(subsurface_models ${QT_LIBRARIES}) \ No newline at end of file