summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2016-01-08 13:11:49 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-01-08 08:04:04 -0800
commit89eed5d36e611f882dbf1e2686ad389f65688fa1 (patch)
treeb7e185df6424d46c9d992ea388a03d4a6b19fd7e /qt-models/CMakeLists.txt
parent7b155774c5105f84303e869317fc946b11b3e78b (diff)
downloadsubsurface-89eed5d36e611f882dbf1e2686ad389f65688fa1.tar.gz
Untangle Library Linkage
with the adittion of gpslistmodel/location, the libraries qt-models had a direct dependency on subsurface-core, and subsurface-core had a direct dependency on qt-models, this is bad. Moving a bit of code around I'v managed to clean this out, and also to clear a bit of uneeded code (GpsTracker and gpsTracker where basically the same thing.) Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index c35ca4377..34e462fa3 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -20,6 +20,8 @@ set(SUBSURFACE_MODELS_LIB_SRCS
divelocationmodel.cpp
divesitepicturesmodel.cpp
ssrfsortfilterproxymodel.cpp
+ divelistmodel.cpp
+ gpslistmodel.cpp
)
source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})