summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-02 19:54:34 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-02 19:54:34 -0800
commit8ea7f404574c2ee571d2dde6bb6be3791e962150 (patch)
tree6a050178bfc71bf10558968f2a3bc0a12d8c525f /qt-models/CMakeLists.txt
parentb273c1b0ca7bfe933e7c83742f1610f6bbe3f4d3 (diff)
parentdf7818a9b8495285b4d9812e5d6d50d6f9c08813 (diff)
downloadsubsurface-8ea7f404574c2ee571d2dde6bb6be3791e962150.tar.gz
Merge branch 'cmakeAndPreferences'
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
new file mode 100644
index 000000000..c9bcf5c3d
--- /dev/null
+++ b/qt-models/CMakeLists.txt
@@ -0,0 +1,29 @@
+# the data models that will interface
+# with the views.
+set(SUBSURFACE_MODELS_LIB_SRCS
+ cleanertablemodel.cpp
+ cylindermodel.cpp
+ diveplannermodel.cpp
+ models.cpp
+ filtermodels.cpp
+ tankinfomodel.cpp
+ weigthsysteminfomodel.cpp
+ weightmodel.cpp
+ divecomputermodel.cpp
+ treemodel.cpp
+ tableprintmodel.cpp
+ yearlystatisticsmodel.cpp
+ divetripmodel.cpp
+ divecomputerextradatamodel.cpp
+ completionmodels.cpp
+ profileprintmodel.cpp
+ divepicturemodel.cpp
+ diveplotdatamodel.cpp
+ divelocationmodel.cpp
+ divesitepicturesmodel.cpp
+ ssrfsortfilterproxymodel.cpp
+)
+
+source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})
+add_library(subsurface_models STATIC ${SUBSURFACE_MODELS_LIB_SRCS})
+target_link_libraries(subsurface_models ${QT_LIBRARIES}) \ No newline at end of file