summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2020-02-08 12:06:57 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-02-08 10:29:36 -0800
commit1a85b0e941b57f4f3c3406a42be78d4d6642d17a (patch)
tree983d895fa634113ed4290f6c5d92306116a0aae7 /qt-models/CMakeLists.txt
parent48ccd114fcb5e1ca0a692c096143c2f24d8254d3 (diff)
downloadsubsurface-1a85b0e941b57f4f3c3406a42be78d4d6642d17a.tar.gz
mobile/summary: create DiveSummaryModel
Instead of passing the dive summary via a completely unstructured QStringList to QML, implement a dynamic model. For potential reuse on desktop (though somewhat unlikely) the model has two interfaces, one for QtWidgets and one for QML. The former is based on columns, whereas the later is based on roles. The number of columns is set dynamically. The roles currently support access to two columns. If more columns should be accessed from QML, more roles have to be added manually. This commit only creates the model and hooks it into QMLs global context, but does not yet change the QML page. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index 8a469a5c2..8cdeecd25 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -53,6 +53,8 @@ set(SUBSURFACE_DESKTOP_MODELS_LIB_SRCS
set(SUBSURFACE_MOBILE_MODELS_LIB_SRCS
divelistmodel.cpp
divelistmodel.h
+ divesummarymodel.cpp
+ divesummarymodel.h
gpslistmodel.cpp
gpslistmodel.h
messagehandlermodel.cpp