summaryrefslogtreecommitdiffstats
path: root/smtk-import/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Robert C. Helling <robert@thetheoreticaldiver.org>2017-06-07 11:00:38 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-06-11 13:50:30 -0700
commit6963b52d9682c09d311ecc2d5a7380b7f1bc77e0 (patch)
tree381e1f498f3d8cdb3969d1af393254185c91c4a4 /smtk-import/CMakeLists.txt
parent22612831bbd302bbc3f68ff377ccb8d53580c812 (diff)
downloadsubsurface-6963b52d9682c09d311ecc2d5a7380b7f1bc77e0.tar.gz
Let command line version not open an X window
So we can run it on a headless system Signed-off-by: Robert C. Helling <helling@atdotde.de>
Diffstat (limited to 'smtk-import/CMakeLists.txt')
-rw-r--r--smtk-import/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/smtk-import/CMakeLists.txt b/smtk-import/CMakeLists.txt
index 3b631be8d..785c23887 100644
--- a/smtk-import/CMakeLists.txt
+++ b/smtk-import/CMakeLists.txt
@@ -3,6 +3,8 @@
project(smtk2ssrf)
cmake_minimum_required(VERSION 2.8.11)
+option(COMMANDLINE "Build command line version")
+
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTOUIC ON)
set(CMAKE_INCLUDE_CURRENT_DIR ON)