summaryrefslogtreecommitdiffstats
path: root/smtk-import/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2020-10-18 00:08:38 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-10-24 15:21:55 -0700
commit1211520ca939e53d6880e213dd38053a08b9589e (patch)
treed76eee0177ff0433baede06a99427087b1741dd9 /smtk-import/CMakeLists.txt
parentb7a586a5b45477b8728301977ad1855234ca6b6b (diff)
downloadsubsurface-1211520ca939e53d6880e213dd38053a08b9589e.tar.gz
build-system: switch to using C++17 as default C++ dialect
Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'smtk-import/CMakeLists.txt')
-rw-r--r--smtk-import/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/smtk-import/CMakeLists.txt b/smtk-import/CMakeLists.txt
index 19761f56a..444506764 100644
--- a/smtk-import/CMakeLists.txt
+++ b/smtk-import/CMakeLists.txt
@@ -85,7 +85,7 @@ endif()
# Set compiler flags and definitions
set(CMAKE_C_STANDARD 99)
set(CMAKE_C_STANDARD_REQUIRED TRUE)
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED TRUE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")