summaryrefslogtreecommitdiffstats
path: root/smtk-import/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Paul Buxton <paulbuxton.mail@googlemail.com>2020-05-30 12:21:22 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-06-25 11:00:51 -0700
commita753845d5acd6d25ff74dc969a9ea6307d8abe6a (patch)
tree04ed77091a154c90f99a3c9903fa293dbddb451a /smtk-import/CMakeLists.txt
parentedc1499e9153907c2901611516a0592db3f56e56 (diff)
downloadsubsurface-a753845d5acd6d25ff74dc969a9ea6307d8abe6a.tar.gz
build-system/MXE: build with more up to date MXE tools.
- use hidapi grantlee and mdbtools from MXE - update MXE version to use QT 5.15, and pull in libzstd and CMake 3.17.3 - fix linking of winmm on windows build with new mxe - add some instructions on building the container - add some new dependancies from QT 5.15 to the packaging - add a patch to MXE to Build qtconnectivity with native-win32-bluetooth [Dirk Hohndel: small refactor] Signed-off-by: Paul Buxton <paulbuxton.mail@googlemail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'smtk-import/CMakeLists.txt')
-rw-r--r--smtk-import/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/smtk-import/CMakeLists.txt b/smtk-import/CMakeLists.txt
index 369dd80a1..19761f56a 100644
--- a/smtk-import/CMakeLists.txt
+++ b/smtk-import/CMakeLists.txt
@@ -92,7 +92,6 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
set(SMTK_LINK_LIBRARIES ${SMTK_LINK_LIBRARIES} -lssh2 -lz -lpthread)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")
- set(SMTK_LINK_LIBRARIES ${SMTK_LINK_LIBRARIES} -lwsock32 -lws2_32 -lole32 -limm32 -lwinmm)
remove_definitions(-DUNICODE)
add_definitions(-mwindows -D_WIN32)
endif()
@@ -109,6 +108,13 @@ set(SMTK_LINK_LIBRARIES ${SMTK_LINK_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES} ${SS
source_group("SmartTrak Import libs" FILES ${SMTK_IMPORT_SRCS})
set(SMTK_IMPORT_TARGET smtk2ssrf)
add_library(smtk_import STATIC ${SMTK_IMPORT_SRCS})
+
+
+if(CMAKE_SYSTEM_NAME STREQUAL "Windows")
+ # Setting the link target this way resolves an issue with not importing timegettime correctly fron winmm
+ target_link_libraries(smtk_import PRIVATE wsock32 ws2_32 ole32 imm32 winmm)
+endif()
+
add_executable(${SMTK_IMPORT_TARGET} smtk_standalone.cpp ${SUBSURFACE_RESOURCES})
# We just want CLI mode on Linux. Silently drop it if cross building to Windows.