summaryrefslogtreecommitdiffstats
path: root/subsurface-core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-06 10:39:59 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-06 11:30:11 -0800
commit9edb4f3fa91b3907809375794d75a1b1a77c94a0 (patch)
treecd3b194081d0b928c5cb56aed0df7b9bc469fdd7 /subsurface-core/CMakeLists.txt
parentbb566f7798f1bc7fe8e4d40813823dca0f6ea9a3 (diff)
downloadsubsurface-9edb4f3fa91b3907809375794d75a1b1a77c94a0.tar.gz
Move ImageDownloader out of the desktop widgets
This required a bit more untangling, but with this it seems we can build subsurface-mobile again (at least on the desktop). Interesting is the removal from inside the ImageDownloader of the call to DivePictureModel::instance()->updateDivePictures() - which actually could cause some interesting recursion issues. If it turns out we did indeed need this, it needs to be re-architected. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'subsurface-core/CMakeLists.txt')
-rw-r--r--subsurface-core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/subsurface-core/CMakeLists.txt b/subsurface-core/CMakeLists.txt
index 9532ff35a..bd4950767 100644
--- a/subsurface-core/CMakeLists.txt
+++ b/subsurface-core/CMakeLists.txt
@@ -76,6 +76,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
metrics.cpp
color.cpp
pluginmanager.cpp
+ imagedownloader.cpp
${SERIAL_FTDI}
${PLATFORM_SRC}
${BT_CORE_SRC_FILES}