summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-07-12 18:24:38 +0200
committerGravatar jan Iversen <jani@apache.org>2018-07-12 18:34:54 +0200
commitd7fed0bcb76cc1742f73577b70df048032f70a61 (patch)
tree9ac66f19797a07b8c5f861ba58d6dcc1c512d797 /tests/CMakeLists.txt
parentf354592050948700f702516d8e3de20977b634fa (diff)
downloadsubsurface-d7fed0bcb76cc1742f73577b70df048032f70a61.tar.gz
tests: update testqml to use shared register_qml_types()
add subsurface-helper.cpp to TestQML target remove local qmlRegisterType() and add register_qml_types() instead Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d0e82e97f..863e9dd8e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -77,7 +77,8 @@ add_definitions(-g)
add_definitions(-DSUBSURFACE_TEST_DATA="${SUBSURFACE_TEST_DATA}")
# Build QML test runner
-add_executable(TestQML testqml.cpp )
+# add_executable demands relative path, therefore ../
+add_executable(TestQML testqml.cpp ../subsurface-helper.cpp )
target_link_libraries(
TestQML
subsurface_corelib