summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-11-18 19:54:30 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-11-19 17:18:33 -0800
commit695950b15a3ab272032f7bd4829ba57044735a70 (patch)
tree08712804ca6cdd599f5cd4896c3bd096613c7c73 /tests/CMakeLists.txt
parent9909cbd2734d45d3fd2dca6c488c9e0a01146e4c (diff)
downloadsubsurface-695950b15a3ab272032f7bd4829ba57044735a70.tar.gz
build-system: fix tests in mobile builds
We can no longer build TestPictures in mobile builds. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d89b47e8c..7f93c3c6a 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -116,7 +116,10 @@ TEST(TestRenumber testrenumber.cpp)
# this keeps randomly failing and I don't understand why
# too many false positives, so disabling this test for now
TEST(TestGitStorage testgitstorage.cpp storageconfig)
+if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
TEST(TestPicture testpicture.cpp)
+set(TEST_PICTURE TestPicture)
+endif()
TEST(TestMerge testmerge.cpp)
TEST(TestTagList testtaglist.cpp)
@@ -157,7 +160,7 @@ add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND}
TestAirPressure
TestDiveSiteDuplication
TestRenumber
- TestPicture
+ ${TEST_PICTURE}
TestMerge
TestTagList
${TEST_PLANNER_SHARED}