summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-02-21 17:23:19 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-02-21 18:22:56 -0800
commit3fef6ec31da786bde7f249dd9c07121944ddd9ee (patch)
treedc1d579f1072a6bf351935165cbafae20099ab7c /tests/CMakeLists.txt
parentc4976b505a2c4a1fe62610b3c875eac56957c924 (diff)
downloadsubsurface-3fef6ec31da786bde7f249dd9c07121944ddd9ee.tar.gz
Simple test case for merging dives
We do some merging in a couple of the other tests as well, but the idea is to have specific test cases that exercise our merge logic. This one starts simple. Merge a dive with some valid info with a second one that has less data filled. And then try it in both possible orders. It shows a few potential problems. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 5106588d0..1aab4ab1c 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -21,6 +21,7 @@ TEST(TestRenumber testrenumber.cpp)
TEST(TestGitStorage testgitstorage.cpp)
TEST(TestPreferences testpreferences.cpp)
TEST(TestPicture testpicture.cpp)
+TEST(TestMerge testmerge.cpp)
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND}
@@ -35,4 +36,5 @@ add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND}
TestPreferences
TestRenumber
TestPicture
+ TestMerge
)