summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2018-10-08 11:35:28 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-10-12 08:22:44 -0700
commit1491616dcf026a53430c8f6895ff27c4a53344d4 (patch)
tree42c2bbe1ed44345ba5b473e8821ef615a89bad54 /tests/CMakeLists.txt
parent34e68d34dd59ff3ebde8312b5645091ab1881216 (diff)
downloadsubsurface-1491616dcf026a53430c8f6895ff27c4a53344d4.tar.gz
Tests: only compile TestHelper if BT support is enabled
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 04b33b459..bd827cea5 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -92,7 +92,9 @@ TEST(TestUnitConversion testunitconversion.cpp)
TEST(TestProfile testprofile.cpp)
TEST(TestGpsCoords testgpscoords.cpp)
TEST(TestParse testparse.cpp)
-TEST(TestHelper testhelper.cpp)
+if (BTSUPPORT)
+ TEST(TestHelper testhelper.cpp)
+endif()
TEST(TestParsePerformance testparseperformance.cpp)
TEST(TestPlan testplan.cpp)
TEST(TestDiveSiteDuplication testdivesiteduplication.cpp)