summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Robert C. Helling <helling@atdotde.de>2017-02-21 10:27:31 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-02-21 13:14:56 -0800
commitc4976b505a2c4a1fe62610b3c875eac56957c924 (patch)
tree1ce720746e8d1314500a5bdd2f1fc57a5089f79e /tests/CMakeLists.txt
parentdbd99f706ecb6074d5f80573a881b98a3e30ce25 (diff)
downloadsubsurface-c4976b505a2c4a1fe62610b3c875eac56957c924.tar.gz
Test for basic image handling
This tests adding image files to dives including hashing and evaluating exif data. Signed-off-by: Robert C. Helling <helling@atdotde.de>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 03f550ae0..5106588d0 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -20,6 +20,8 @@ TEST(TestDiveSiteDuplication testdivesiteduplication.cpp)
TEST(TestRenumber testrenumber.cpp)
TEST(TestGitStorage testgitstorage.cpp)
TEST(TestPreferences testpreferences.cpp)
+TEST(TestPicture testpicture.cpp)
+
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND}
DEPENDS
@@ -32,4 +34,5 @@ add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND}
TestDiveSiteDuplication
TestPreferences
TestRenumber
+ TestPicture
)