summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jeremie Guichard <djebrest@gmail.com>2018-04-09 10:09:34 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-04-09 07:59:51 -0700
commit7753352e6210ae69c2a79bdf2387eaca46becc64 (patch)
tree88c2594af6ff7c87b7923c7b3625653f3b5d7cfe /tests/CMakeLists.txt
parentf1830cd44e75ac552e09dfd79f6ec9e0d90f8808 (diff)
downloadsubsurface-7753352e6210ae69c2a79bdf2387eaca46becc64.tar.gz
Change taglist_get_tagstring to support 'unlimited' tag list size
Previous taglist_get_tagstring signature/implementation did not allow handling of cases where inputted buffer could not contain all tags. New implementation allocates buffer based on pre-computed size allowing to insert all tags in the returned string. Added get_taglist_string in qthelper to handle conversion to QString Added TestTagList with tests for taglist_get_tagstring Signed-off-by: Jeremie Guichard <djebrest@gmail.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 2efacd706..a9c65bd09 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -87,6 +87,7 @@ TEST(TestGitStorage testgitstorage.cpp)
TEST(TestPreferences testpreferences.cpp)
TEST(TestPicture testpicture.cpp)
TEST(TestMerge testmerge.cpp)
+TEST(TestTagList testtaglist.cpp)
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND}
@@ -102,6 +103,7 @@ add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND}
TestRenumber
TestPicture
TestMerge
+ TestTagList
)
# useful for debugging CMake issues