summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-30 14:01:03 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-31 06:33:46 -0700
commit78cd2f4e0927ca1790e030a993a309d97c70ecb6 (patch)
treedd4c410a7fa002fd43c4597a4b5df50149b6e6f6 /tests/CMakeLists.txt
parent59a68fe9b5bdeb2d557a26c58e43564169fa7746 (diff)
downloadsubsurface-78cd2f4e0927ca1790e030a993a309d97c70ecb6.tar.gz
Add performance test case
This requires the user to manually copy the large test file into the dives directory (because I really don't want to add this to the repo); instructions how to do that are displayed if the file is missing. Next it uses the git version of that same file (but prefetches it to try and remove the network speed from what is being measured). Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4d59536bd..252d0d3d8 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -92,6 +92,7 @@ TEST(TestUnitConversion testunitconversion.cpp)
TEST(TestProfile testprofile.cpp)
TEST(TestGpsCoords testgpscoords.cpp)
TEST(TestParse testparse.cpp)
+TEST(TestParsePerformance testparseperformance.cpp)
TEST(TestPlan testplan.cpp)
TEST(TestDiveSiteDuplication testdivesiteduplication.cpp)
TEST(TestRenumber testrenumber.cpp)