summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-04-03 20:39:31 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-04-12 12:59:17 +0300
commit1f4777a2877e1df3215e03e48204333cb160a2c6 (patch)
tree82b1488e3033eaf9648128d04846817df0c735a3 /tests/CMakeLists.txt
parentcf86ece73e6bc7fed2b251791f5e7e6103ee25cf (diff)
downloadsubsurface-1f4777a2877e1df3215e03e48204333cb160a2c6.tar.gz
CMake: move enable_testing() to the top level
This allows calling ctest from the main build directory instead of having to change one level down. As a bonus the unittests now show up in my KDevelop so I can directly run them from the IDE. Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 447a85033..229054631 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -73,7 +73,6 @@ function(TEST NAME FILE)
endif()
endfunction()
-enable_testing()
add_definitions(-g)
add_definitions(-DSUBSURFACE_TEST_DATA="${SUBSURFACE_TEST_DATA}")