summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b197bfc3e..c1d86caef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -152,6 +152,7 @@ SET(SUBSURFACE_CORE_LIB_SRCS
devicedetails.cpp
configuredivecomputer.cpp
configuredivecomputerthreads.cpp
+ divesitehelpers.cpp
)
#the interface, in C++
@@ -265,6 +266,9 @@ MACRO(test NAME FILE)
ENDMACRO()
ENABLE_TESTING()
+ADD_DEFINITIONS(-DSUBSURFACE_SOURCE="${CMAKE_SOURCE_DIR}")
+ADD_DEFINITIONS(-g)
test(TestUnitConversion testunitconversion.cpp)
test(TestProfile testprofile.cpp)
test(TestGpsCoords testgpscoords.cpp)
+test(TestParse testparse.cpp)