summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a0716ea6..d28678345 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,7 @@ include(cmake/Modules/pkgconfig_helper.cmake)
# if you think a module miss anything, take a look on the specific
# module file.
include(cmake/Modules/HandleFindGit2.cmake)
+include(cmake/Modules/HandleFindLibDiveComputer.cmake)
pkg_config_library(LIBXML libxml-2.0 REQUIRED)
pkg_config_library(LIBSQLITE3 sqlite3 REQUIRED)
@@ -99,14 +100,6 @@ if(SMARTTRAK_IMPORT)
pkg_config_library(LIBMDB libmdb REQUIRED)
endif()
-if(LIBDC_FROM_PKGCONFIG)
- pkg_config_library(LIBDC libdivecomputer REQUIRED)
- set(LIBDIVECOMPUTER_LIBRARIES "")
-else()
- find_package(Libdivecomputer REQUIRED)
- include_directories(${LIBDIVECOMPUTER_INCLUDE_DIR})
-endif()
-
# setup marble
if(NOT NO_MARBLE)