summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a3bf27f1..0be935399 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,6 +91,7 @@ include(cmake/Modules/HandleFindLibDiveComputer.cmake)
include(cmake/Modules/HandleFindMarble.cmake)
include(cmake/Modules/HandleFindGrantlee.cmake)
include(cmake/Modules/HandleFtdiSupport.cmake)
+include(cmake/Modules/HandleUserManual.cmake)
include(cmake/Modules/HandleVersionGeneration.cmake)
pkg_config_library(LIBXML libxml-2.0 REQUIRED)
@@ -109,14 +110,6 @@ if(ANDROID)
set(NO_PRINTING ON)
endif()
-if(NO_USERMANUAL)
- message(STATUS "building without usermanual")
- add_definitions(-DNO_USERMANUAL)
-else()
- set(WEBKIT_PKG WebKitWidgets)
- set(WEBKIT_LIB Qt5::WebKitWidgets)
-endif()
-
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${LIBUSB_LIBRARIES})
# configure Qt.