summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e278427e..2bccbecd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,15 +102,10 @@ else()
include_directories(${LIBGIT2_INCLUDE_DIR})
if(FORCE_LIBSSH)
find_package(Libssh2 QUIET CONFIG)
- find_package(Libssh2 REQUIRED)
if ("${LIBSSH2_VERSION}" STRGREATER "1.6.1")
set(LIBSSH2_LIBRARIES Libssh2::libssh2)
endif()
- get_cmake_property(_variableNames VARIABLES)
- foreach (_variableName ${_variableNames})
- message(STATUS "${_variableName}=${${_variableName}}")
- endforeach()
- if(!Libssh2_FOUND OR "${Libssh2_FOUND}" STREQUAL "")
+ if(!Libssh2_FOUND AND !LIBSSH2_FOUND)
pkg_config_library(LIBSSH2 libssh2 REQUIRED)
endif()
endif()