summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 763f8ec26..bd36966c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -480,6 +480,12 @@ elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
if(NOT NO_MARBLE)
install(DIRECTORY marbledata/maps DESTINATION share/subsurface/data)
install(DIRECTORY marbledata/bitmaps DESTINATION share/subsurface/data)
+ else()
+ add_custom_target(link_googlemaps_plugin ALL COMMAND
+ rm -rf ./geoservices &&
+ mkdir -p geoservices &&
+ ln -sf
+ ${CMAKE_SOURCE_DIR}/../install-root/usr/lib/qt/plugins/geoservices/libqtgeoservices_googlemaps.so ${CMAKE_BINARY_DIR}/geoservices)
endif()
install(FILES subsurface.debug DESTINATION bin)
install(FILES subsurface.desktop DESTINATION share/applications)