summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt38
1 files changed, 19 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c825e50b..d47a1d502 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -294,27 +294,27 @@ target_link_libraries(export-html subsurface_corelib ${SUBSURFACE_LINK_LIBRARIES
# install a few things so that one can run Subsurface from the build
# directory
- add_custom_target(themeLink ALL
+add_custom_target(themeLink ALL
+ COMMAND
+ rm -f ${CMAKE_BINARY_DIR}/theme &&
+ ln -s ${CMAKE_SOURCE_DIR}/theme ${CMAKE_BINARY_DIR}/theme
+)
+if(NOT NO_PRINTING)
+ add_custom_target(printing_templatesLink ALL
COMMAND
- rm -f ${CMAKE_BINARY_DIR}/theme &&
- ln -s ${CMAKE_SOURCE_DIR}/theme ${CMAKE_BINARY_DIR}/theme
+ rm -f ${CMAKE_BINARY_DIR}/printing_templates &&
+ ln -s ${CMAKE_SOURCE_DIR}/printing_templates ${CMAKE_BINARY_DIR}/printing_templates
)
- if(NOT NO_PRINTING)
- add_custom_target(printing_templatesLink ALL
- COMMAND
- rm -f ${CMAKE_BINARY_DIR}/printing_templates &&
- ln -s ${CMAKE_SOURCE_DIR}/printing_templates ${CMAKE_BINARY_DIR}/printing_templates
- )
- endif()
- if(NOT NO_DOCS)
- add_custom_target(
- documentationLink ALL
- COMMAND
- mkdir -p ${CMAKE_BINARY_DIR}/Documentation/ &&
- rm -rf ${CMAKE_BINARY_DIR}/Documentation/images &&
- ln -s ${CMAKE_SOURCE_DIR}/Documentation/images ${CMAKE_BINARY_DIR}/Documentation/images
- )
- endif()
+endif()
+if(NOT NO_DOCS)
+ add_custom_target(
+ documentationLink ALL
+ COMMAND
+ mkdir -p ${CMAKE_BINARY_DIR}/Documentation/ &&
+ rm -rf ${CMAKE_BINARY_DIR}/Documentation/images &&
+ ln -s ${CMAKE_SOURCE_DIR}/Documentation/images ${CMAKE_BINARY_DIR}/Documentation/images
+ )
+endif()
if(NOT NO_DOCS)
add_custom_target(
documentation ALL