summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 329a5e19b..74accf273 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,20 +38,7 @@ ELSE()
INCLUDE_DIRECTORIES(${LIBGIT2_INCLUDE_DIRS})
ENDIF()
-SET(LIBDCDEVEL "" CACHE STRING "libraries")
-IF(DEFINED LIBDCDEVEL)
- cmake_policy(SET CMP0015 OLD)
- include_directories(${LIBDCDEVEL}/include )
- link_directories(${LIBDCDEVEL}/src/.libs)
- if(NOT DEFINED LIBDCSTATIC)
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -ldivecomputer -lusb-1.0)
- ELSE()
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} libdivecomputer.a -lusb-1.0)
- ENDIF()
-ELSE()
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -ldivecomputer)
-ENDIF()
-
+FIND_PACKAGE(Libdivecomputer REQUIRED)
FIND_PACKAGE(Marble REQUIRED)
include_directories(${MARBLE_INCLUDE_DIR})