summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 17 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b911f2bc..f2d299d91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ set(CMAKE_AUTOUIC ON)
option(LIBGIT2_FROM_PKGCONFIG "use pkg-config to retrieve libgit2" OFF)
option(LIBDC_FROM_PKGCONFIG "use pkg-config to retrieve libdivecomputer" OFF)
option(LIBGRANTLEE_FROM_PKGCONFIG "use pkg-config to retrieve grantlee" OFF)
+option(LIBMARBLE_FROM_PKGCONFIG "use pkg-config to retrieve marble" OFF)
option(NO_MARBLE "disable the marble widget" OFF)
option(NO_TESTS "disable the tests" OFF)
option(NO_DOCS "disable the docs" OFF)
@@ -109,14 +110,24 @@ else()
include_directories(${LIBDIVECOMPUTER_INCLUDE_DIR})
endif()
-# optional marble
+# setup marble
+
if(NOT NO_MARBLE)
- find_package(Marble QUIET)
- if(MARBLE_FOUND)
- include_directories(${MARBLE_INCLUDE_DIR})
+ if(LIBMARBLE_FROM_PKGCONFIG)
+ pkg_config_library(MARBLE libmarble REQUIRED)
+ set(MARBLE_LIBRARIES "")
else()
- set(NO_MARBLE ON)
+ find_package(MARBLE QUIET)
+ if(MARBLE_FOUND)
+ include_directories(${MARBLE_INCLUDE_DIR})
+ else()
+ set(NO_MARBLE ON)
+ endif()
endif()
+else()
+ message(STATUS "building without marble widget support")
+ add_definitions(-DNO_MARBLE)
+ set(MARBLE_LIBRARIES "")
endif()
if(FTDISUPPORT)
@@ -129,12 +140,6 @@ if(FTDISUPPORT)
add_definitions(-DSERIAL_FTDI)
endif()
-if(NO_MARBLE)
- message(STATUS "building without marble widget support")
- add_definitions(-DNO_MARBLE)
- set(MARBLE_LIBRARIES "")
-endif()
-
if(ANDROID)
set(FBSUPPORT OFF)
set(NO_PRINTING ON)
@@ -187,7 +192,7 @@ get_filename_component(PARENTDIR ${${PROJECT_NAME}_SOURCE_DIR} PATH)
string(COMPARE EQUAL "${${PROJECT_NAME}_SOURCE_DIR}" "${PARENTDIR}" insourcesubdir)
if(NOT (insource OR insourcedir))
if(NOT NO_MARBLE)
- add_custom_target(link_marble_data ALL COMMAND rm -f marbledata && ln -s ${${PROJECT_NAME}_SOURCE_DIR}/marbledata ${${PROJECT_NAME}_BINARY_DIR}/marbledata)
+ add_custom_target(link_marble_data ALL COMMAND rm -rf ./marbledata && ln -s ${${PROJECT_NAME}_SOURCE_DIR}/marbledata ${${PROJECT_NAME}_BINARY_DIR}/marbledata)
endif()
endif()