summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 478712f46..d618106d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,11 @@ if (POLICY CMP0071)
cmake_policy(SET CMP0071 OLD)
endif()
+# support Packagename_ROOT environment variable
+if (POLICY CMP0074)
+ cmake_policy(SET CMP0074 NEW) # CMake 3.12
+endif ()
+
# global settings
set(CMAKE_MODULE_PATH