summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5d7dd89c..011d4d776 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,8 +6,11 @@
project(Subsurface)
cmake_minimum_required(VERSION 2.8.11)
-# don't process generated files
-cmake_policy(SET CMP0071 OLD)
+# don't process generated files - this is new in 3.10 - but
+# VERSION_GREATER_EQUAL did get added until 3.7
+if(${CMAKE_VERSION} VERSION_EQUAL "3.10.0" OR ${CMAKE_VERSION} VERSION_GREATER "3.10.0")
+ cmake_policy(SET CMP0071 OLD)
+endif()
# global settings