summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 77521d6a1..5622f5e65 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -24,6 +24,11 @@ if(BTSUPPORT)
set(BT_CORE_SRC_FILES qtserialbluetooth.cpp)
endif()
+if(BLESUPPORT)
+ add_definitions(-DBLE_SUPPORT)
+ set(BT_CORE_SRC_FILES qt-ble.cpp)
+endif()
+
# compile the core library, in C.
set(SUBSURFACE_CORE_LIB_SRCS
btdiscovery.cpp