summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 5c22e2306..dff8361e5 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -18,6 +18,12 @@ if(FTDISUPPORT)
set(SERIAL_FTDI serial_ftdi.c)
endif()
+if(CP2130SUPPORT)
+ message(STATUS "building with cp2130 support")
+ add_definitions(-DSERIAL_CP2130)
+ set(SERIAL_CP2130 serial_cp2130.c)
+endif()
+
if(BTSUPPORT)
add_definitions(-DBT_SUPPORT)
set(BT_SRC_FILES desktop-widgets/btdeviceselectiondialog.cpp)
@@ -89,6 +95,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
subsurface-qt/CylinderObjectHelper.cpp
subsurface-qt/SettingsObjectWrapper.cpp
${SERIAL_FTDI}
+ ${SERIAL_CP2130}
${PLATFORM_SRC}
${BT_CORE_SRC_FILES}
)