summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index d3f1401f1..58ffa67e4 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -2,12 +2,12 @@ set(PLATFORM_SRC unknown_platform.c)
message(STATUS "system name ${CMAKE_SYSTEM_NAME}")
if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
if(ANDROID)
- set(PLATFORM_SRC android.cpp)
+ set(PLATFORM_SRC android.cpp serial_usb_android.cpp)
else()
set(PLATFORM_SRC unix.c)
endif()
elseif(CMAKE_SYSTEM_NAME STREQUAL "Android")
- set(PLATFORM_SRC android.cpp)
+ set(PLATFORM_SRC android.cpp serial_usb_android.cpp)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(PLATFORM_SRC macos.c)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")