summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index d8f5cd5a9..a2beffa5c 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -13,7 +13,9 @@ include_directories(.
)
add_subdirectory(preferences)
-add_subdirectory(plugins)
+if(NOT DISABLE_PLUGINS)
+ add_subdirectory(plugins)
+endif()
# the interface, in C++
set(SUBSURFACE_INTERFACE