summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index 2c373b83f..635a8b68e 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -75,23 +75,6 @@ endif()
source_group("Subsurface Interface" FILES ${SUBSURFACE_INTERFACE})
-# the profile widget
-set(SUBSURFACE_PROFILE_LIB_SRCS
- profile/profilewidget2.cpp
- profile/diverectitem.cpp
- profile/divepixmapitem.cpp
- profile/divelineitem.cpp
- profile/divetextitem.cpp
- profile/animationfunctions.cpp
- profile/divecartesianaxis.cpp
- profile/diveprofileitem.cpp
- profile/diveeventitem.cpp
- profile/divetooltipitem.cpp
- profile/ruleritem.cpp
- profile/tankitem.cpp
-)
-source_group("Subsurface Profile" FILES ${SUBSURFACE_PROFILE_LIB_SRCS})
-
# the yearly statistics widget.
set(SUBSURFACE_STATISTICS_LIB_SRCS
statistics/statisticswidget.cpp
@@ -101,8 +84,6 @@ set(SUBSURFACE_STATISTICS_LIB_SRCS
)
source_group("Subsurface Statistics" FILES ${SUBSURFACE_STATISTICS_LIB_SRCS})
-add_library(subsurface_profile STATIC ${SUBSURFACE_PROFILE_LIB_SRCS})
-target_link_libraries(subsurface_profile ${QT_LIBRARIES})
add_library(subsurface_statistics STATIC ${SUBSURFACE_STATISTICS_LIB_SRCS})
target_link_libraries(subsurface_statistics ${QT_LIBRARIES})
add_library(subsurface_generated_ui STATIC ${SUBSURFACE_UI_HDRS})