summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/preferences/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-widgets/preferences/CMakeLists.txt')
-rw-r--r--desktop-widgets/preferences/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/desktop-widgets/preferences/CMakeLists.txt b/desktop-widgets/preferences/CMakeLists.txt
index 953c587b1..6af8b4a73 100644
--- a/desktop-widgets/preferences/CMakeLists.txt
+++ b/desktop-widgets/preferences/CMakeLists.txt
@@ -1,9 +1,21 @@
# the profile widget
+include_directories(.
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+)
+
+file(GLOB SUBSURFACE_PREFERENCES_UI *.ui)
+qt5_wrap_ui(SUBSURFACE_PREFERENCES_UI_HDRS ${SUBSURFACE_PREFERENCES_UI})
+
+source_group("Subsurface Interface Files" FILES ${SUBSURFACE_PREFERENCES_UI})
+
set(SUBSURFACE_PREFERENCES_LIB_SRCS
abstractpreferenceswidget.cpp
+ preferences_language.cpp
)
source_group("Subsurface Preferences" FILES ${SUBSURFACE_PREFERENCES_LIB_SRCS})
-add_library(subsurface_desktop_preferences STATIC ${SUBSURFACE_PREFERENCES_LIB_SRCS})
-target_link_libraries(subsurface_desktop_preferences ${QT_LIBRARIES}) \ No newline at end of file
+add_library(subsurface_desktop_preferences STATIC ${SUBSURFACE_PREFERENCES_LIB_SRCS} ${SUBSURFACE_PREFERENCES_UI_HDRS})
+target_link_libraries(subsurface_desktop_preferences ${QT_LIBRARIES})
+