summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/preferences/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-widgets/preferences/CMakeLists.txt')
-rw-r--r--desktop-widgets/preferences/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/desktop-widgets/preferences/CMakeLists.txt b/desktop-widgets/preferences/CMakeLists.txt
new file mode 100644
index 000000000..953c587b1
--- /dev/null
+++ b/desktop-widgets/preferences/CMakeLists.txt
@@ -0,0 +1,9 @@
+# the profile widget
+set(SUBSURFACE_PREFERENCES_LIB_SRCS
+ abstractpreferenceswidget.cpp
+)
+
+source_group("Subsurface Preferences" FILES ${SUBSURFACE_PREFERENCES_LIB_SRCS})
+
+add_library(subsurface_desktop_preferences STATIC ${SUBSURFACE_PREFERENCES_LIB_SRCS})
+target_link_libraries(subsurface_desktop_preferences ${QT_LIBRARIES}) \ No newline at end of file