summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/preferences/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-widgets/preferences/CMakeLists.txt')
-rw-r--r--desktop-widgets/preferences/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/desktop-widgets/preferences/CMakeLists.txt b/desktop-widgets/preferences/CMakeLists.txt
new file mode 100644
index 000000000..4e506ed73
--- /dev/null
+++ b/desktop-widgets/preferences/CMakeLists.txt
@@ -0,0 +1,27 @@
+# the profile widget
+include_directories(.
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+)
+
+file(GLOB SUBSURFACE_PREFERENCES_UI *.ui)
+qt5_wrap_ui(SUBSURFACE_PREFERENCES_UI_HDRS ${SUBSURFACE_PREFERENCES_UI})
+
+source_group("Subsurface Interface Files" FILES ${SUBSURFACE_PREFERENCES_UI})
+
+set(SUBSURFACE_PREFERENCES_LIB_SRCS
+ abstractpreferenceswidget.cpp
+ preferencesdialog.cpp
+ preferences_language.cpp
+ preferences_georeference.cpp
+ preferences_defaults.cpp
+ preferences_units.cpp
+ preferences_graph.cpp
+ preferences_network.cpp
+)
+
+source_group("Subsurface Preferences" FILES ${SUBSURFACE_PREFERENCES_LIB_SRCS})
+
+add_library(subsurface_desktop_preferences STATIC ${SUBSURFACE_PREFERENCES_LIB_SRCS} ${SUBSURFACE_PREFERENCES_UI_HDRS})
+target_link_libraries(subsurface_desktop_preferences ${QT_LIBRARIES})
+