summaryrefslogtreecommitdiffstats
path: root/packaging/ubuntu/debian
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/ubuntu/debian')
-rw-r--r--packaging/ubuntu/debian/copyright4
-rwxr-xr-xpackaging/ubuntu/debian/rules16
2 files changed, 15 insertions, 5 deletions
diff --git a/packaging/ubuntu/debian/copyright b/packaging/ubuntu/debian/copyright
index 75e69b368..f8f20b50e 100644
--- a/packaging/ubuntu/debian/copyright
+++ b/packaging/ubuntu/debian/copyright
@@ -7,8 +7,8 @@ Copyright: 2011-2014 Dirk Hohndel, Linus Torvalds, Tomaz Canabrava and others
License: GPL-2.0
Files: debian/*
-Copyright: 2014 Dirk Hohndel <dirk@hohndel.org>
-License: GPL-2.0
+Copyright: 2012 Khalid El Fathi <khalid@elfathi.fr>, 2013-2014 Sylvestre Ledru <sylvestre@debian.org>, 2014-2015 Dirk Hohndel <dirk@hohndel.org>
+License: GPL-2.0+
License: GPL-2.0
This package is free software; you can redistribute it and/or modify
diff --git a/packaging/ubuntu/debian/rules b/packaging/ubuntu/debian/rules
index ef197521c..e1ad26a3d 100755
--- a/packaging/ubuntu/debian/rules
+++ b/packaging/ubuntu/debian/rules
@@ -3,10 +3,11 @@
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
-
+export DEB_BUILD_OPTIONS+=nocheck
+export DEB_CMAKE_INSTALL_PREFIX=/usr
%:
- dh $@
+ dh $@ --buildsystem=cmake --builddirectory=subsurface-build --parallel
override_dh_auto_clean:
(cd libdivecomputer ; make clean || true)
@@ -32,7 +33,16 @@ override_dh_auto_configure:
ln -s src/lib/marble lib ; \
mkdir include ; cd include ; for i in `find ../../marble-source -name \*.h` ; do ln -s $$i . ; done ; \
ln -s . marble )
- qmake LIBDCDEVEL=./libdivecomputer LIBGIT2DEVEL=./libgit2 LIBGIT2STATIC=1 LIBMARBLEDEVEL=./marble-build SPECIAL_MARBLE_PREFIX=1 subsurface.pro
+ (mkdir subsurface-build ; cd subsurface-build ; \
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DPREFER_GIT_FROMSOURCE=1 \
+ -DLIBGIT2_INCLUDE_DIR=$$(pwd)/../libgit2/include \
+ -DLIBGIT2_LIBRARIES=$$(pwd)/../libgit2/build/libgit2.a \
+ -DLIBDIVECOMPUTER_INCLUDE_DIR=$$(pwd)/../libdivecomputer/include \
+ -DLIBDIVECOMPUTER_LIBRARIES=$$(pwd)/../libdivecomputer/src/.libs/libdivecomputer.a \
+ -DMARBLE_INCLUDE_DIR=$$(pwd)/../marble-build/include \
+ -DMARBLE_LIBRARIES=$$(pwd)/../marble-build/lib/libssrfmarblewidget.so \
+ $$(pwd)/.. ; )
override_dh_installchangelogs:
dh_installchangelogs