summaryrefslogtreecommitdiffstats
path: root/profile-widget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'profile-widget/CMakeLists.txt')
-rw-r--r--profile-widget/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/profile-widget/CMakeLists.txt b/profile-widget/CMakeLists.txt
new file mode 100644
index 000000000..f0a1d8439
--- /dev/null
+++ b/profile-widget/CMakeLists.txt
@@ -0,0 +1,19 @@
+# the profile widget
+set(SUBSURFACE_PROFILE_LIB_SRCS
+ profilewidget2.cpp
+ diverectitem.cpp
+ divepixmapitem.cpp
+ divelineitem.cpp
+ divetextitem.cpp
+ animationfunctions.cpp
+ divecartesianaxis.cpp
+ diveprofileitem.cpp
+ diveeventitem.cpp
+ divetooltipitem.cpp
+ ruleritem.cpp
+ tankitem.cpp
+)
+source_group("Subsurface Profile" FILES ${SUBSURFACE_PROFILE_LIB_SRCS})
+
+add_library(subsurface_profile STATIC ${SUBSURFACE_PROFILE_LIB_SRCS})
+target_link_libraries(subsurface_profile ${QT_LIBRARIES}) \ No newline at end of file