summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
new file mode 100644
index 000000000..463d61412
--- /dev/null
+++ b/qt-models/CMakeLists.txt
@@ -0,0 +1,28 @@
+# the data models that will interface
+# with the views.
+set(SUBSURFACE_MODELS_LIB_SRCS
+ cleanertablemodel.cpp
+ cylindermodel.cpp
+ diveplannermodel.cpp
+ models.cpp
+ filtermodels.cpp
+ tankinfomodel.cpp
+ weigthsysteminfomodel.cpp
+ weightmodel.cpp
+ divecomputermodel.cpp
+ treemodel.cpp
+ tableprintmodel.cpp
+ yearlystatisticsmodel.cpp
+ divetripmodel.cpp
+ divecomputerextradatamodel.cpp
+ completionmodels.cpp
+ profileprintmodel.cpp
+ divepicturemodel.cpp
+ diveplotdatamodel.cpp
+ divelocationmodel.cpp
+ divesitepicturesmodel.cpp
+ ssrfsortfilterproxymodel.cpp
+)
+source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})
+add_library(subsurface_models STATIC ${SUBSURFACE_MODELS_LIB_SRCS})
+target_link_libraries(subsurface_models ${QT_LIBRARIES}) \ No newline at end of file