summaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index 8cdeecd25..aa3aa1886 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -17,6 +17,8 @@ set(SUBSURFACE_GENERIC_MODELS_LIB_SRCS
diveplannermodel.h
diveplotdatamodel.cpp
diveplotdatamodel.h
+ divetripmodel.cpp
+ divetripmodel.h
maplocationmodel.cpp
maplocationmodel.h
models.cpp
@@ -39,6 +41,10 @@ set(SUBSURFACE_DESKTOP_MODELS_LIB_SRCS
divetripmodel.h
filtermodels.cpp
filtermodels.h
+ models.cpp
+ models.h
+ tankinfomodel.cpp
+ tankinfomodel.h
treemodel.cpp
treemodel.h
weightmodel.cpp
@@ -59,6 +65,8 @@ set(SUBSURFACE_MOBILE_MODELS_LIB_SRCS
gpslistmodel.h
messagehandlermodel.cpp
messagehandlermodel.h
+ mobilelistmodel.cpp
+ mobilelistmodel.h
)
if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")