aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-12-14 22:15:12 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-24 08:44:23 +0900
commit0ab8bd5ecaf0cbd92387283e3c21aa47f72ce977 (patch)
tree85e8831833179237c92d22b745d19f72e2a6461d /CMakeLists.txt
parenta4d299e01e216ef2db61d98d304d091da39ee51d (diff)
downloadsubsurface-0ab8bd5ecaf0cbd92387283e3c21aa47f72ce977.tar.gz
build-system: add new root dir backend-shared
WARNING: multi directory commit, needed to secure it builds. leaving the shared backend sources in core, imposes a severe limitation, that they cannot make use of e.g. qt-models, because that is created after core (first library to be created). The shared backend uses functionality from core and qt-models, so it must be created when those are available and before desktop-widgets or mobile-widgets are created. Make a new root directory "backend-shared" with empty CMakeLists.txt Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f46393243..55589f830 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,6 +280,7 @@ add_subdirectory(commands)
add_subdirectory(profile-widget)
add_subdirectory(map-widget)
add_subdirectory(mobile-widgets)
+add_subdirectory(backend-shared)
if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
add_subdirectory(desktop-widgets)