aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-11-14 19:21:16 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-12-03 13:26:55 -0800
commit5a8db978198682734cdecc69a480d21a16775d4a (patch)
tree21ec80d98c7f063e2cd8fc24075dab9f933c91b3 /CMakeLists.txt
parent057c151fe8592ec5f160ae5f7891c1f1b5c998dc (diff)
downloadsubsurface-5a8db978198682734cdecc69a480d21a16775d4a.tar.gz
build-system: add models and shared backends to the downloader
We'll need this in order to be able to actually open dive files and download things from a dive computer. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d48617afa..18428778f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -393,6 +393,9 @@ elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DownloaderExecutable")
add_executable(${SUBSURFACE_TARGET} MACOSX_BUNDLE WIN32 ${SUBSURFACE_PKG} ${DOWNLOADER_APP} ${SUBSURFACE_RESOURCES})
target_link_libraries(
${SUBSURFACE_TARGET}
+ subsurface_backend_shared
+ subsurface_models_downloader
+ subsurface_commands
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
)