aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-26 14:51:07 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-26 14:51:07 -0700
commit5d8f3c1ebd6983db50991a5dd2dc7b794a7909a6 (patch)
tree1ec7eec3a5ab2662b457ac8c6e2ae3f70802f380 /CMakeLists.txt
parent47c7958ed3545a4c1dd316b0404cc37f6cd72aef (diff)
downloadsubsurface-5d8f3c1ebd6983db50991a5dd2dc7b794a7909a6.tar.gz
Cmake: fix incorrect modification of a QT_LIBRARIES
It's a list, not a string. Treating it as a string creates all kinds of exciting weird errors that make no sense. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e9321eee..3b7845704 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -214,7 +214,7 @@ set(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test)
if (BTSUPPORT AND "${Qt5Core_VERSION_STRING}" STRLESS "5.4.0")
set(BTSUPPORT OFF)
message(STATUS "Turning off Bluetooth support as Qt version ${Qt5Core_VERSION_STRING} is insufficiant for that")
- string(REPLACE "Qt5::Bluetooth" "" QT_LIBRARIES ${QT_LIBRARIES})
+ list(REMOVE_ITEM QT_LIBRARIES Qt5::Bluetooth)
endif()
# Generate the ssrf-config.h every 'make'